Usare gli oggetti OLE

La funzione OLE (Object Linking and Embedding) di Windows ti permette di importare oggetti che sono stati creati usando altri software installati sul tuo computer, come fogli di calcolo ed elaboratori di testi.

Inserire oggetti OLE

  • Dal menu Modifica, seleziona Inserisci nuovo oggetto.
    mceclip0.png
  • Seleziona il tipo di oggetto che vuoi creare.

Solo i programmi che sono installati sul tuo computer e che supportano OLE appaiono nell'elenco.
mceclip2.png

  • Selezionare Create New per creare un nuovo oggetto OLE usando l'applicazione selezionata.

Selezionate Display as Icon per mostrare l'oggetto OLE semplicemente come un'icona. Fate clic su Change Icon per cambiare l'aspetto dell'icona.

  • Il programma selezionato si avvierà con un nuovo documento.
  • Crea o importa dati nel nuovo documento.
  • Salva il documento quando hai finito.

Ecco un esempio di un foglio di calcolo Excel OLE. Come il foglio di calcolo cambia, l'oggetto OLE in Flexi si aggiornerà automaticamente, cambiando le dimensioni come necessario. Se ho bisogno di modificare i dati dell'oggetto OLE in Flexi, devo riaprire Microsoft Excel, aprire il foglio di calcolo e modificare i dati lì.

mceclip4.png

Inserire file esistenti come oggetti OLE

  • Selezionare Create from File
    mceclip6.png
  • Clicca su Browse e individua il file da inserire
    • Selezionare Display As Icon per mostrare l'oggetto OLE semplicemente come un'icona. Fare clic su Change Icon per cambiare l'icona.
    • Selezionate Link per collegare il file selezionato. L'oggetto nel file sarà memorizzato a parte rispetto al documento, e tutte le modifiche fatte nel file di origine saranno riflesse nel tuo documento. Se l'opzione Link è deselezionata, l'oggetto sarà incorporato e memorizzato all'interno del documento.
  • Fai clic su OK.

Modifica degli oggetti OLE

  • Selezionare l'oggetto OLE desiderato. (Fare doppio clic su un oggetto OLE ha lo stesso effetto di selezionare Modifica).
  • Dal menu Modifica, puntate su [...] Oggetto e cliccate su Modifica o Apri. Il nome del sottomenu dipende dal tipo di oggetto OLE.
    mceclip9.png
    • Quando si seleziona Modifica, il programma associato all'oggetto OLE si avvia in una finestra all'interno del documento e si chiude dopo la modifica.
    • Se scegliete Open, si avvierà un'istanza completa del programma. Si può lasciare questa applicazione in esecuzione anche dopo aver modificato l'oggetto OLE.

La chiusura dell'oggetto originale chiuderà l'applicazione, a meno che un altro file sia ancora aperto nell'applicazione.

Conversione di oggetti OLE in un altro formato

  • Selezionare l'oggetto OLE desiderato.
  • Dal menu Modifica, puntate su [...] Oggetto e selezionate Converti. Il nome del sottomenu dipende dal tipo di oggetto OLE.
    mceclip7.png
  • Selezionare il nuovo formato dall'elenco.
  • Cliccate su OK.

Conversione di oggetti OLE in segmenti di base e bitmap

1. Selezionare l'oggetto OLE desiderato.

2. Dal menu Arrange, selezionare Convert Linked to Native. Questo convertirà il file in un file bitmap all'interno di Flexi. Non farà più riferimento al file esterno.

 

Cambiare le proprietà di collegamento degli oggetti OLE

  • Dal menu Edit, selezionare Links.
  • Selezionare il collegamento dell'oggetto desiderato.
  • Cambiare le seguenti opzioni di collegamento:
Automatico / Manuale Determina se le informazioni collegate si aggiornano automaticamente quando si apre il documento o manualmente quando si sceglie di aggiornarle.
Aggiorna ora Aggiorna l'oggetto OLE nel documento per riflettere il contenuto attuale del file originale quando è selezionata la modalità Manuale.
Apri sorgente Apre il file oggetto collegato usando il programma associato.
Cambia sorgente Cambia il file oggetto collegato, sostituendo il file corrente con un altro.
Interrompi collegamento Dà la possibilità di interrompere permanentemente il collegamento tra un oggetto collegato e il suo file sorgente.
Questo articolo ti è stato utile?
Utenti che ritengono sia utile: 0 su 0