Uso de objetos OLE

La función OLE (Object Linking and Embedding) de Windows permite importar objetos creados con otro software instalado en el ordenador, como hojas de cálculo y procesadores de texto.

Inserción de objetos OLE

  • En el menú Edición, seleccione Insertar nuevo objeto.
    mceclip0.png
  • Seleccione el tipo de objeto que desea crear.

Sólo aparecen en la lista los programas que están instalados en su ordenador y que soportan OLE.
mceclip2.png

  • Seleccione Crear nuevo para crear un nuevo objeto OLE utilizando la aplicación seleccionada.

Marque Mostrar como icono para mostrar el objeto OLE simplemente como un icono. Haga clic en Cambiar icono para cambiar la apariencia del icono.

  • El programa seleccionado se iniciará con un nuevo documento.
  • Cree o importe datos en el nuevo documento.
  • Guarde el documento cuando haya terminado.

Este es un ejemplo de una hoja de cálculo OLE de Excel. A medida que la Hoja de Cálculo cambia, el objeto OLE en Flexi se actualizará automáticamente, cambiando el tamaño según sea necesario. Si necesito editar los datos del objeto OLE en Flexi, volvería a abrir Microsoft Excel, abriría la hoja de cálculo y editaría los datos allí.

mceclip4.png

Inserción de archivos existentes como objetos OLE

  • Seleccione Crear desde archivo
    mceclip6.png
  • Haga clic en Examinar y localice el archivo a insertar
    • Marque Mostrar como icono para mostrar el objeto OLE simplemente como un icono. Haga clic en Cambiar icono para cambiar el icono.
    • Marque Vincular para vincular el archivo seleccionado. El objeto en el archivo se almacenará aparte del documento, y todos los cambios realizados en el archivo fuente se reflejarán en su documento. Si la opción Enlace no está marcada, el objeto se incrustará y se almacenará dentro del documento.
  • Haga clic en Aceptar.

Editar objetos OLE

  • Seleccione el objeto OLE deseado. (Hacer doble clic en un objeto OLE tiene el mismo efecto que seleccionar Editar).
  • En el menú Editar, señale [...] Objeto y haga clic en Editar o Abrir. El nombre del submenú dependerá del tipo de objeto OLE.
    mceclip9.png
    • Si selecciona Editar, el programa asociado al objeto OLE se iniciará en una ventana dentro de su documento y se cerrará después de la edición.
    • Si selecciona Abrir, se iniciará una instancia completa del programa. Puede dejar esta aplicación en funcionamiento incluso después de editar el objeto OLE.

Al cerrar el objeto original se cerrará la aplicación, a no ser que todavía haya otro archivo abierto en la aplicación.

Convertir objetos OLE a otro formato

  • Seleccione el objeto OLE deseado.
  • En el menú Edición, señale [...] Objeto y seleccione Convertir. El nombre del submenú dependerá del tipo de objeto OLE.
    mceclip7.png
  • Seleccione el nuevo formato de la lista.
  • Haga clic en Aceptar.

Convertir objetos OLE en segmentos básicos y mapas de bits

1. Seleccione el objeto OLE deseado.

2. En el menú Organizar, seleccione Convertir enlazado a nativo. Esto convertirá el archivo en un archivo de mapa de bits dentro de Flexi. Ya no hará referencia al archivo externo.

 

Cambiar las propiedades de enlace de los objetos OLE

  • En el menú Edición, seleccione Enlaces.
  • Seleccione el enlace del objeto deseado.
  • Cambie las siguientes opciones de enlace:
Automático / Manual Determina si la información vinculada se actualiza automáticamente cuando se abre el documento o manualmente cuando se decide actualizarla.
Actualizar ahora Actualiza el objeto OLE en el documento para reflejar el contenido actual del archivo original cuando se selecciona el modo Manual.
Abrir fuente Abre el archivo del objeto vinculado utilizando el programa asociado.
Cambiar origen Cambia el archivo del objeto vinculado, sustituyendo el archivo actual por otro.
Romper enlace Le da la opción de romper permanentemente la conexión entre un objeto vinculado y su archivo fuente.
¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0