Flexi 21 System Requirements

Supported Operating Systems:

  • Windows 10 32-bit (x86) or 64-bit (x64) processor

  • Windows 8.1 32-bit (x86) or 64-bit (x64) processor

  • Only the latest build of Flexi 21 works with Windows 11 (Flexi 21 SP 3614)

Linux, Android, iOS, and ARM devices are not supported.

While Flexi may successfully run in virtualized environments (such as BootCamp), you will not receive any assistance from our Tech Support team to help it run or to connect devices. It highly recommended you use a dedicated Windows or Mac Desktop environment with the latest version available.

Recommended Hardware Requirements

RAM 16GB - 32GB
CPU   3GHz, Intel i5 or i7 equivalent
Display 1920x1080 resolution, 24-bit color
Disk Space SSD with 256GB or more. HHD with 500GB working space or more.

Internet connection required for license activation as well as cloud window features and services

Was this article helpful?
1 out of 1 found this helpful